$re = '/\$\{(.*?)\}/';
$str = '{
"type" : "id",
"id" : ${idOf(\'/tar/check/inof/high1\')},
"details" : [
{
"name" : "Sanio",
"sig" : "DA123QW"
},
{
"name" : "${anotherOne}",
"sig" : "BAWE3QW"
},
{
"name" : "Kadek",
"sig" : "KSWE2J"
},
]
},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);