// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$\{(.*?)\}").unwrap();
let string = "{
\"type\" : \"id\",
\"id\" : ${idOf('/tar/check/inof/high1')},
\"details\" : [
{
\"name\" : \"Sanio\",
\"sig\" : \"DA123QW\"
},
{
\"name\" : \"${anotherOne}\",
\"sig\" : \"BAWE3QW\"
},
{
\"name\" : \"Kadek\",
\"sig\" : \"KSWE2J\"
},
]
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}