package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^.+(video\/|\/watch\?v=|embed\/)([a-z0-9_?=-]+)$`)
var str = `http://www.youtube.com/video/ZNvzVScj8ws
https://www.youtube.com/watch?v=ZNvzVScj8ws
http://www.youtube-nocookie.com/embed/ZNvzVScj8ws`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}