import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+(video\\/|\\/watch\\?v=|embed\\/)([a-z0-9_?=-]+)$";
final String string = "http://www.youtube.com/video/ZNvzVScj8ws\n"
+ "https://www.youtube.com/watch?v=ZNvzVScj8ws\n"
+ "http://www.youtube-nocookie.com/embed/ZNvzVScj8ws";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}