const regex = /\b(\d+)(\d{2})\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)(\\d{2})\\b', '')
const str = `34535325`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);