import re
regex = re.compile(r"\b(\d+)(\d{2})\b")
test_str = "34535325"
subst = "$1.$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)