use strict;
my $str = '34535325';
my $regex = qr/\b(\d+)(\d{2})\b/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";