#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[DE\](.*?)\[\/DE\]"
Local $sString = "[DE]lkjhkjh" & @CRLF & _
"" & @CRLF & _
"huhu[/DE]" & @CRLF & _
"" & @CRLF & _
"[EN]" & @CRLF & _
"lkjlkjlkjlkjhkhj" & @CRLF & _
"sjdkjdhfksjfhsdkshkjhf" & @CRLF & _
"sfksjdksjfkdsfksjdfh" & @CRLF & _
"skjfkjskfjdsfh" & @CRLF & _
"dsjfhskjfdkjsfhd" & @CRLF & _
"" & @CRLF & _
"[/EN]" & @CRLF & _
"" & @CRLF & _
"[DE]" & @CRLF & _
"lsdkflkdsj" & @CRLF & _
"kjlskdjfldj" & @CRLF & _
"kjlskdjlksfdljs" & @CRLF & _
"flkslfkslfsdkfldsfdskfljdsk" & @CRLF & _
"lksjdlkslfdkslfsdfkjfs" & @CRLF & _
"jkjhkjkjhkjh" & @CRLF & _
"lkjlkljjlkjklj" & @CRLF & _
"[/DE]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")