import re
regex = re.compile(r"\[DE\](.*?)\[\/DE\]", flags=re.DOTALL)
test_str = ("[DE]lkjhkjh\n\n"
"huhu[/DE]\n\n"
"[EN]\n"
"lkjlkjlkjlkjhkhj\n"
"sjdkjdhfksjfhsdkshkjhf\n"
"sfksjdksjfkdsfksjdfh\n"
"skjfkjskfjdsfh\n"
"dsjfhskjfdkjsfhd\n\n"
"[/EN]\n\n"
"[DE]\n"
"lsdkflkdsj\n"
"kjlskdjfldj\n"
"kjlskdjlksfdljs\n"
"flkslfkslfsdkfldsfdskfljdsk\n"
"lksjdlkslfdkslfsdfkjfs\n"
"jkjhkjkjhkjh\n"
"lkjlkljjlkjklj\n"
"[/DE]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")