using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\brules\s+\{|(?!^)\G)\s+([\w-]+)";
string input = @"regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}