re = /(?:\brules\s+\{|(?!^)\G)\s+([\w-]+)/i
str = 'regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end