$re = '/(?:\brules\s+\{|(?!^)\G)\s+([\w-]+)/is';
$str = 'regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);