package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(?s)^.*\brules\s*[{]\s*([^{}]+)[}].*$`)
var str = `regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}