const regex = /(?s)^.*\brules\s*[{]\s*([^{}]+)[}].*$/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^.*\\brules\\s*[{]\\s*([^{}]+)[}].*$', 'gis')
const str = `regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}