// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)(?s)^.*\brules\s*[{]\s*([^{}]+)[}].*$").unwrap();
let string = "regulations { qux def } standards none rules { abc-123 456-defghi wxyz_678 } security { enabled }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}