# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img\s[^>]*?data-src-l\s*=\s*['\"])([^'\"]*?['\"])([^>]*?>)/$1http:\/\/www.asaphshop.nl$2$3/gm;t' <<< "<li>
<a href=\"/WebRoot/products/8020/80203122/bilder/80203122.jpg\">
<img
itemprop=\"image\"
alt=\"Jesus Remember Me - Taize Songs (2CD)\"
src=\"/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg\"
data-src-xs=\"/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg\"
data-src-s=\"/WebRoot/products/8020/80203122/bilder/80203122_s.jpg\"
data-src-m=\"/WebRoot/products/8020/80203122/bilder/80203122_m.jpg\"
data-src-l=\"/WebRoot/products/8020/80203122/bilder/80203122.jpg\"
/>
</a>
</li>
</ul>"