import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img\\s[^>]*?data-src-l\\s*=\\s*['\\\"])([^'\\\"]*?['\\\"])([^>]*?>)";
final String string = "<li>\n"
+ " <a href=\"/WebRoot/products/8020/80203122/bilder/80203122.jpg\">\n"
+ " <img\n"
+ " itemprop=\"image\"\n"
+ " alt=\"Jesus Remember Me - Taize Songs (2CD)\"\n"
+ " src=\"/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg\"\n"
+ " data-src-xs=\"/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg\"\n"
+ " data-src-s=\"/WebRoot/products/8020/80203122/bilder/80203122_s.jpg\"\n\n"
+ " data-src-m=\"/WebRoot/products/8020/80203122/bilder/80203122_m.jpg\"\n\n"
+ " data-src-l=\"/WebRoot/products/8020/80203122/bilder/80203122.jpg\"\n"
+ " />\n"
+ " </a>\n"
+ " </li>\n\n"
+ "</ul>";
final String subst = "$1http://www.asaphshop.nl$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}