#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<img\s[^>]*?data-src-l\s*=\s*['\"])([^'\"]*?['\"])([^>]*?>)"
Local $sString = "<li>" & @CRLF & _
" <a href="/WebRoot/products/8020/80203122/bilder/80203122.jpg">" & @CRLF & _
" <img" & @CRLF & _
" itemprop="image"" & @CRLF & _
" alt="Jesus Remember Me - Taize Songs (2CD)"" & @CRLF & _
" src="/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg"" & @CRLF & _
" data-src-xs="/WebRoot/AsaphNL/Shops/asaphnl/5422/8F43/62EE/D698/EF8E/4DEB/AED5/3B0E/80203122_xs.jpg"" & @CRLF & _
" data-src-s="/WebRoot/products/8020/80203122/bilder/80203122_s.jpg"" & @CRLF & _
"" & @CRLF & _
" data-src-m="/WebRoot/products/8020/80203122/bilder/80203122_m.jpg"" & @CRLF & _
"" & @CRLF & _
" data-src-l="/WebRoot/products/8020/80203122/bilder/80203122.jpg"" & @CRLF & _
" />" & @CRLF & _
" </a>" & @CRLF & _
" </li>" & @CRLF & _
"" & @CRLF & _
"</ul>"
Local $sSubst = "$1http://www.asaphshop.nl$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)