package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?(0?|(([1-9]{1}\d{0,2})(,\d{1,3})*|[1-9]+\d*))(\.(0{1}|\d*[1-9]{1})(e(0|[1-9]{1}\d*))?)?$`)
var str = `12.4e1200000000000000000000000000000000000000000000000000000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}