import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(0?|(([1-9]{1}\\d{0,2})(,\\d{1,3})*|[1-9]+\\d*))(\\.(0{1}|\\d*[1-9]{1})(e(0|[1-9]{1}\\d*))?)?$";
final String string = "12.4e1200000000000000000000000000000000000000000000000000000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}