const regex = /^-?(0?|(([1-9]{1}\d{0,2})(,\d{1,3})*|[1-9]+\d*))(\.(0{1}|\d*[1-9]{1})(e(0|[1-9]{1}\d*))?)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(0?|(([1-9]{1}\\d{0,2})(,\\d{1,3})*|[1-9]+\\d*))(\\.(0{1}|\\d*[1-9]{1})(e(0|[1-9]{1}\\d*))?)?$', '')
const str = `12.4e1200000000000000000000000000000000000000000000000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}