const regex = /(rgba?.*?\))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(rgba?.*?\\))', 'gmi')
const str = `linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}