re = /(rgba?.*?\))/mi
str = 'linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end