$re = '/(rgba?.*?\))/mi';
$str = 'linear-gradient(to bottom,rgba(255,0,0,0.4) 0,rgb(0,230,175) 100%);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);