$re = '/\s*\(.*\)\s*/m';
$str = 'RomFile01(US).rom
RomFile02 (EU).rom
RomFile03 (USA) .rom
RomFile04 (Japan) .rom
RomFile05 (Europe) .rom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);