re = /\s*\(.*\)\s*/m
str = 'RomFile01(US).rom
RomFile02 (EU).rom
RomFile03 (USA) .rom
RomFile04 (Japan) .rom
RomFile05 (Europe) .rom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end