using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""(?P<filename>[\p{L}\d\s\[\]_,.\-\(\)\+]+\.(?P<extension>\w{1,5}))\""(?!.*\""([\p{L}\d\s\.\[\]_,.\-\(\)\+]+\.\w{1,5})\""))";
string input = @"Re: Author/Series not in file name - Ambler, Eric - ""Journey into Fear v.1.0.txt"" yEnc (1/2) - ""Ambler, Eric - Journey Into Fear [txt].rar"" 122.7 kBytes yEnc";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}