use strict;
my $str = 'Re: Author/Series not in file name - Ambler, Eric - "Journey into Fear v.1.0.txt" yEnc (1/2) - "Ambler, Eric - Journey Into Fear [txt].rar" 122.7 kBytes yEnc';
my $regex = qr/(\"(?P<filename>[\p{L}\d\s\[\]_,.\-\(\)\+]+\.(?P<extension>\w{1,5}))\"(?!.*\"([\p{L}\d\s\.\[\]_,.\-\(\)\+]+\.\w{1,5})\"))/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}