$re = '/(\"(?P<filename>[\p{L}\d\s\[\]_,.\-\(\)\+]+\.(?P<extension>\w{1,5}))\"(?!.*\"([\p{L}\d\s\.\[\]_,.\-\(\)\+]+\.\w{1,5})\"))/';
$str = 'Re: Author/Series not in file name - Ambler, Eric - "Journey into Fear v.1.0.txt" yEnc (1/2) - "Ambler, Eric - Journey Into Fear [txt].rar" 122.7 kBytes yEnc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);