import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S.{0,39}(?<=\\S)(?!\\S)";
final String string = "abcd (efghij # / klmno (# #)\n"
+ "blah blah etc etc words and more words and yet more words. What about these words?\n"
+ "And some more text for this string so that we can test things out. \n\n"
+ " test test test test test \n\n"
+ "a\n\n"
+ " abcd (efghij # / klmno (# #)\n"
+ "blah blah etc etc words and more words and yet more words. What about these words?\n"
+ "And some more text for this string so that we can test things out. \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}