import re
regex = re.compile(r"\S.{0,39}(?<=\S)(?!\S)", flags=re.MULTILINE)
test_str = ("abcd (efghij # / klmno (# #)\n"
"blah blah etc etc words and more words and yet more words. What about these words?\n"
"And some more text for this string so that we can test things out. \n\n"
" test test test test test \n\n"
"a\n\n"
" abcd (efghij # / klmno (# #)\n"
"blah blah etc etc words and more words and yet more words. What about these words?\n"
"And some more text for this string so that we can test things out. \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")