#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?isx)(?:\<\!\-\-(?:(?!\-\-\>)\r\n?|\n|.)*?-\-\>)|(?:<(\S+)\s+(?=.*>)|(?<=[=\s])\G)(?:((?:(?!\s|=).)*)\s*?=\s*?[\"']?((?:(?<=\")(?:(?<=\\)\"|[^\"])*|(?<=')(?:(?<=\\)'|[^'])*)|(?:(?!\"|')(?:(?!\/>|>|\s).)+))[\"']?\s*)"
Local $sString = "In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:" & @CRLF & _
"" & @CRLF & _
"<img src='http://example.com/whatever.jpg'>" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img src=http://example.com/whatever.jpg>" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img border=0 src="http://example.com/whatever.jpg">" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img" & @CRLF & _
" src="http://example.com/whatever.jpg">" & @CRLF & _
"or you start getting false positives from" & @CRLF & _
"" & @CRLF & _
"<!-- // commented out" & @CRLF & _
"<img src="http://example.com/outdated.png">" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<asd ASD=asd>" & @CRLF & _
"" & @CRLF & _
"<!-- // commented out <img src="http://example.com/outdated.png"> -->" & @CRLF & _
"" & @CRLF & _
"No quotes:" & @CRLF & _
"<iframe src=test.html target=xyz></iframe>" & @CRLF & _
"Self-closing tag:" & @CRLF & _
"<a href=test.html target=xyz/>" & @CRLF & _
"Self closing tag with a space before closure:" & @CRLF & _
"<a href=test.html target=xyz />" & @CRLF & _
"Double quotes:" & @CRLF & _
"<a href="test.html" target="xyz">" & @CRLF & _
"Single quotes:" & @CRLF & _
"<a href='test.html' target='xyz'>" & @CRLF & _
"Escaping double quotes:" & @CRLF & _
"<a href="test.html?val=1" title="\"No rules exist\" Andre Breton's quote">" & @CRLF & _
"Escaping single quotes (also with spaces between equals signs):" & @CRLF & _
"<a href = "test.html?val=1" title = 'Charlie\'s Angels'>" & @CRLF & _
"Tag without opening (ignore attributes):" & @CRLF & _
"a href = "test.html?val=1" title='Charlie\'s Angels'>" & @CRLF & _
"Tag without closure (ignore attributes):" & @CRLF & _
"<a href = "test.html?val=1" title='Charlie\'s Angels'" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")