using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\<\!\-\-(?:(?!\-\-\>)\r\n?|\n|.)*?-\-\>)|(?:<(\S+)\s+(?=.*>)|(?<=[=\s])\G)(?:((?:(?!\s|=).)*)\s*?=\s*?[\""']?((?:(?<=\"")(?:(?<=\\)\""|[^\""])*|(?<=')(?:(?<=\\)'|[^'])*)|(?:(?!\""|')(?:(?!\/>|>|\s).)+))[\""']?\s*)";
string input = @"In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:
<img src='http://example.com/whatever.jpg'>
or
<img src=http://example.com/whatever.jpg>
or
<img border=0 src=""http://example.com/whatever.jpg"">
or
<img
src=""http://example.com/whatever.jpg"">
or you start getting false positives from
<!-- // commented out
<img src=""http://example.com/outdated.png"">
-->
<asd ASD=asd>
<!-- // commented out <img src=""http://example.com/outdated.png""> -->
No quotes:
<iframe src=test.html target=xyz></iframe>
Self-closing tag:
<a href=test.html target=xyz/>
Self closing tag with a space before closure:
<a href=test.html target=xyz />
Double quotes:
<a href=""test.html"" target=""xyz"">
Single quotes:
<a href='test.html' target='xyz'>
Escaping double quotes:
<a href=""test.html?val=1"" title=""\""No rules exist\"" Andre Breton's quote"">
Escaping single quotes (also with spaces between equals signs):
<a href = ""test.html?val=1"" title = 'Charlie\'s Angels'>
Tag without opening (ignore attributes):
a href = ""test.html?val=1"" title='Charlie\'s Angels'>
Tag without closure (ignore attributes):
<a href = ""test.html?val=1"" title='Charlie\'s Angels'
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}