const regex = /(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\d{1,2}) (?P<yellow_key>(COMB )?Comdty)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\\d{1,2}) (?P<yellow_key>(COMB )?Comdty)', 'gm')
const str = `VBYU4 Comdty`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}