// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<symbol>[0-9]?[A-Z]+)(?P<contract>[FGHJKMNQUVXZ]+\d{1,2}) (?P<yellow_key>(COMB )?Comdty)").unwrap();
let string = "VBYU4 Comdty";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}