const regex = /.*?,(.*) New York,.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?,(.*) New York,.*', 'gm')
const str = `10 Fake St, Unit #5, New York, NY 10001 10 Fake St, Units #5,6,7, New York, NY 10001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}