// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?,(.*) New York,.*").unwrap();
let string = "10 Fake St, Unit #5, New York, NY 10001 10 Fake St, Units #5,6,7, New York, NY 10001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}