$re = '/.*?,(.*) New York,.*/m';
$str = '10 Fake St, Unit #5, New York, NY 10001 10 Fake St, Units #5,6,7, New York, NY 10001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);