using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`(?P<class>\w+)>>(?P<method>(?:\w+):?(?:(?:(?:\w+):)+))`";
string input = @"`GHRequester>>blabla:blabl:`";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}