package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(``(?P<class>\w+)>>(?P<method>(?:\w+):?(?:(?:(?:\w+):)+))``)
var str = `\`GHRequester>>blabla:blabl:\``
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}