#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Numer właściciela:\h*(?<owner_id>\S+(?:\h\S+)*)"
Local $sString = "Numer właściciela: NOWAKOWSKA 01-234 Warsaw" & @CRLF & _
"Numer właściciela: NOWAK_S6_2" & @CRLF & _
"Numer właściciela: KOWALSKA_S6_ 01-234 Warsaw" & @CRLF & _
"Numer właściciela: NOWACKI S6_ 01-234 Warsaw"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")