import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Numer właściciela:\\h*(?<owner_id>\\S+(?:\\h\\S+)*)";
final String string = "Numer właściciela: NOWAKOWSKA 01-234 Warsaw\n"
+ "Numer właściciela: NOWAK_S6_2\n"
+ "Numer właściciela: KOWALSKA_S6_ 01-234 Warsaw\n"
+ "Numer właściciela: NOWACKI S6_ 01-234 Warsaw";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}