package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Numer właściciela:\h*(?<owner_id>\S+(?:\h\S+)*)`)
var str = `Numer właściciela: NOWAKOWSKA 01-234 Warsaw
Numer właściciela: NOWAK_S6_2
Numer właściciela: KOWALSKA_S6_ 01-234 Warsaw
Numer właściciela: NOWACKI S6_ 01-234 Warsaw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}