#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+"
Local $sString = "Phase 1 plots in Al Furjan" & @CRLF & _
"75% paid" & @CRLF & _
"25% to pay in November 2014" & @CRLF & _
"" & @CRLF & _
"6,544 sq ft plot with BUA of 4,908 sq ft " & @CRLF & _
"" & @CRLF & _
"Call Nicoleta 055-5573564 or email: nicoleta.mihoc@group7properties.com" & @CRLF & _
"" & @CRLF & _
"Al Furjan is located in a convenient location just off the Emirates Road and the Dubai Investment Park Road within the Jebel Ali community Zone. This 560 Hectare Mega development is consisted of family town houses & villas of 3 to 6 bedrooms, and will offer a much needed boost for family villas within the commuter zone of Dubai." & @CRLF & _
"" & @CRLF & _
"Inspired by a historic Arabic phrase from Dubai's proud past, Al Furjan symbolizes a collection of homes or a small village. " & @CRLF & _
"A "fareej" (a single village) represented a way of life to its residents, one that created a community of extended family and friends, rather than merely neighbors."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")