import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z0-9-.]+";
final String string = "Phase 1 plots in Al Furjan\n"
+ "75% paid\n"
+ "25% to pay in November 2014\n\n"
+ "6,544 sq ft plot with BUA of 4,908 sq ft \n\n"
+ "Call Nicoleta 055-5573564 or email: nicoleta.mihoc@group7properties.com\n\n"
+ "Al Furjan is located in a convenient location just off the Emirates Road and the Dubai Investment Park Road within the Jebel Ali community Zone. This 560 Hectare Mega development is consisted of family town houses & villas of 3 to 6 bedrooms, and will offer a much needed boost for family villas within the commuter zone of Dubai.\n\n"
+ "Inspired by a historic Arabic phrase from Dubai's proud past, Al Furjan symbolizes a collection of homes or a small village. \n"
+ "A \"fareej\" (a single village) represented a way of life to its residents, one that created a community of extended family and friends, rather than merely neighbors.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}