re = /[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+/m
str = 'Phase 1 plots in Al Furjan
75% paid
25% to pay in November 2014
6,544 sq ft plot with BUA of 4,908 sq ft
Call Nicoleta 055-5573564 or email: nicoleta.mihoc@group7properties.com
Al Furjan is located in a convenient location just off the Emirates Road and the Dubai Investment Park Road within the Jebel Ali community Zone. This 560 Hectare Mega development is consisted of family town houses & villas of 3 to 6 bedrooms, and will offer a much needed boost for family villas within the commuter zone of Dubai.
Inspired by a historic Arabic phrase from Dubai\'s proud past, Al Furjan symbolizes a collection of homes or a small village.
A "fareej" (a single village) represented a way of life to its residents, one that created a community of extended family and friends, rather than merely neighbors.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end