const regex = new RegExp('<\\?=?(?!php\\b)', 'gm')
const str = `<?=code
<?code`;
const subst = `<php `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);