$re = '~<\?=?(?!php\b)~m';
$str = '<?=code
<?code';
$subst = "<php ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;