use strict;
my $str = 'public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
return;
}
public String getAsSeparateGroup(String groupName) {
String begin = pattern.substring(0,getStart());
String mid = pattern.substring(getStart(),getEnd());
String finish = pattern.substring(getEnd());
return begin + "(?<" + groupName + ">" + mid + ")" + finish;
}
@Override
public static final String toString() {
return asString;
}
public String directMatch(String match) {
Matcher matcher = Pattern.compile(getAsSeparateGroup("test")).matcher(match);
matcher.find();
String result;
try {
result = matcher.group("test");
}catch (Exception ex) {
result = "empty";
}
return getPattern() + ":" + result;
}
}';
my $regex = qr/^(?<indent>\s*)(?<mod1>\w+)\s(?<mod2>\w+)?\s*(?<mod3>\w+)?\s*(?<return>\b\w+)\s(?<name>\w+)\((?<arg>.*?)\)\s*\{(?<body>.+?)^\k<indent>\}/msp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";