// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^(?<indent>\s*)(?<mod1>\w+)\s(?<mod2>\w+)?\s*(?<mod3>\w+)?\s*(?<return>\b\w+)\s(?<name>\w+)\((?<arg>.*?)\)\s*\{(?<body>.+?)^\k<indent>\}").unwrap();
let string = "public static FieldsConfig getFieldsConfig(){
if(xxx) {
sssss;
}
return;
}
public String getAsSeparateGroup(String groupName) {
String begin = pattern.substring(0,getStart());
String mid = pattern.substring(getStart(),getEnd());
String finish = pattern.substring(getEnd());
return begin + \"(?<\" + groupName + \">\" + mid + \")\" + finish;
}
@Override
public static final String toString() {
return asString;
}
public String directMatch(String match) {
Matcher matcher = Pattern.compile(getAsSeparateGroup(\"test\")).matcher(match);
matcher.find();
String result;
try {
result = matcher.group(\"test\");
}catch (Exception ex) {
result = \"empty\";
}
return getPattern() + \":\" + result;
}
}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}